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Super-Fine Detail (SFD): A Primer
Introduction
SFD or Super Fine Detail is a sophisticated exposure bracketing and processing technique that
combines the best parts of seven (7) bracketed exposures to deliver the highest quality finished
image. Images produced using SFD have fewer issues with blown highlights and shadow noise. SFD
can capture up to 6 more stops of light than a single image. Although conceptually similar to High
Dynamic Range (HDR), SFD preserves far more detail.
•

SFD is an excellent tool where very large prints are to be produced and/or where fine detail
is extremely important. It is an especially useful tool for macro photography.

•

SFD works with Quattro cameras only - sd Quattro, sd Quattro H and dp Quattro.

•

At present, SFD does not handle subject or camera motion, so it is recommended for use
only with still subjects, and care should be taken to eliminate camera shake/vibration. We
recommend that you review the sections in this document that address improving
equipment stability, reducing motion and vibration, and selecting suitable subjects.

Note: This document assumes you have some experience with the Sigma cameras and with the
Sigma RAW processor, Sigma Photo Pro (SPP). If you are not experienced with processing Sigma X3F
images using SPP, we recommend that you spend some time familiarizing yourself with this product.
Also, if you are not familiar with the SD Quattro cameras, we recommend you spend some time with
any one of the Quattro cameras shooting RAW before you try SFD.

Getting Started
What you need to know before using SFD – CAMERA
•

SFD is turned on and off via the camera menu (2nd CAMERA Menu, SFD Mode). It says on
until you turn it off. It captures seven (7) bracketed RAW shots with one press of the shutter
button. With the SD Quattro and the SD Quattro H, there is a lag between the 6th and 7th
shot due to the buffer being full, so be sure that the 7th shot has been taken before
touching the camera/tripod etc. The dp Quattro series have no such lag.

•

There is no option in camera to change the number of images in an SFD sequence set.

•

SFD is compatible with SPP 6.4 or later. Dp series require SPP 6.5.3 or later.

•

SFD defaults to ISO100. There is no option to use any other ISO value.

•

SFD produces a file with the extension X3I and an approximate size of 350 MB for sd Quattro
and 500MB for sd Quattro H. The file has the seven bracketed X3F files integrated and ready
for processing. This set of all seven RAW images is called the Default Sequence Set.

•

The X3I file uses portions of the standard X3F format.

•

The X3I file has a single embedded JPEG preview that is taken from one of the X3Fs. The
thumbnail image that you see of the X3I is not a composite of the seven shots.
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What you need to know before using SFD – SPP
In this document we refer to four windows. The Main Window displays X3I and/or X3I thumbs. The
Review Window is the standard (default) window for processing X3F and X3I RAW files. The X3I Edit
Window is multi-functional window for custom work and X3F extraction and is discussed in detail
later. The Alternate Review Window is used for limited-choice processing of X3I only and is
discussed later.
There are two options which should be set before starting. They are accessed from the MAIN
WINDOW by clicking the File tab and selecting Preferences. The first, X3I File Setting, sets which
window opens when you double-click in the MAIN WINDOW on an X3I thumbnail image - the X3I
EDIT Window or the REVIEW WINDOW. The second, Applicable Adjustment Setting (X3I), sets
processing type (Auto or Default X3I) when you open the X3I file in the REVIEW WINDOW.
•

In order to see X3I image files in the MAIN WINDOW (thumbnails), click on the View tab and
select either: Display All Formats, Display Still Only or Display X3I Only.

•

The X3I can be processed in the REVIEW WINDOW and with the same editing options as an
X3F file. When the X3I file is first produced, the seven X3Fs have been integrated and the X3I
file is ready to be processed using all seven images.

•

In the X3I EDIT WINDOW you can process the X3I with its default set (7 images) or review
individual X3Fs and build a smaller set. The minimum X3Fs in a custom sequence set is three
(3). Two different processing windows are available from this window and are detailed
below.

•

In the X3I EDIT WINDOW you can also export one or all of the embedded X3Fs from the X3I
and process them as stand-alone files.

•

The X3I file contains an embedded JPEG from one of the X3F files which can be extracted via
SPP in the same way a JPEG is extracted from an X3F file. In the MAIN WINDOW, either rightclick the thumb or highlight the thumb and select the option from the File tab.

X3I files have the following default settings in SPP:
•

Detail is set to 0.00 (Smooth).

•

NR Chroma and Luminance, 0.00

•

Contrast -2.0; Shadow +2.0; Saturation -0.3; Sharpness, -2.0;

•

Highlight Control (not to be confused with Tonal Highlight slider) and Overexposure
Adjustment are not enabled.

•

All other adjustments are set to 0 or left unset.

X3F files have the following default settings:
•

Detail 0.50; Highlight Control 1.0 (not to be confused with Tonal Highlight slider).

•

NR Chroma, .50 and NR Luminance, .50 (Mid Points)

•

All other adjustments are set to 0 or left unset.
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•

You CANNOT edit/change the settings of the embedded X3F files while they are within the
X3I file. You can export them and edit them individually. You cannot import an exported X3F
back into the X3I file.

Processing Options
Processing from the MAIN WINDOW
Processing options are the same as those for an X3F file except those noted above. Since you are in
the default REVIEW WINDOW, there is no way to change the Sequence Set in the X3I file from this
window. There are four ways to open the REVIEW WINDOW from the MAIN WINDOW.
1. Double-click the thumbnail image. This option must be set in the Preferences section of the
MAIN WINDOW.
2. Right-click and choose Review Image Color.
3. Right-click and choose Review Image Monochrome. Color images are converted to
Monochrome.
4. Right-click and choose Open New Review Window.
Processing from the X3I EDIT Window
The functions which can be performed from the X3I EDIT WINDOW are:
1. Review embedded X3F files - thumbs or larger size. The larger size is especially helpful in
selecting which individual X3F files are to be used when creating a custom sequence set. You
can also adjust brightness.
2. Build and integrate a custom sequence set composed of between 3 and 7 X3Fs.
3. Process the X3I file using the default or custom sequence set in the REVIEW WINDOW with
full editing options.
4. Process the X3I file using the default or custom sequence set in the ALTERNATE REVIEW
WINDOW, a smaller window limited to choices of X3F, Auto, or Custom. No individual
edits/adjustments can be made.
5. Extract one or all X3Fs from the X3I file for individual processing.
Opening the X3I Edit Window:
There are two ways to open an X3I in the X3I EDIT WINDOW from the MAIN WINDOW. The window
will open with the seven embedded X3Fs displayed on the bottom as thumbs and numbered from
left to right as X3I number with _1 to _7 appended.
1. Right-click on the thumb and select Open in X3I Edit Window.
2. Click the thumbnail, click the File tab and then select Open in X3I Edit Window.
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X3I Edit Window upon Opening
Reviewing X3F thumbs
1. Click a thumbnail image to show it in the DISPLAY PANE; the default size is FIT. To return an
image to FIT, double-click the image or click the Fit icon on the bottom of the screen.
There are three options for magnifying the image and two options for adjusting brightness.
2. Right-click on the image in the DISPLAY PANE for 400%, 200%, Actual, and Fit.
3. Select the slider under the thumbs and to the right of the Fit button for a series from 12.5%
to 800%.
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4. Click on the image in the DISPLAYPANE and the image will be magnified. Double-click and
the size returns to FIT.
5. You can temporarily change brightness by clicking on the View tab and selecting Adjusting
Image Brightness. This button is a single-action on/off. Overexposed will have brightness
reduced; underexposed, increased.
6. You can also click Brightness button to the left of the Magnification slider. This button is a
single-action on/off. Overexposed will have brightness reduced; underexposed, increased.

X3I Edit Window With Display Pane Magnification
(Right portion cropped out)
Building the Integration File
By default, all seven X3Fs are integrated into the X3I. All seven thumbs have ticked boxes indicating
they are integrated or ready to be integrated. The minimum number of X3Fs that must be selected
to build and integrate a custom sequence set is three. This is a two-step process.
Choose (by ticking and un-ticking the thumbs). Then integrate either by clicking the File tab and
selecting Save Integration Flag Information; or by clicking on the X3I Button at the top of the screen
and just to the left of the Check button. If you see the “No Images Selected” message while doing
this, ignore it. This message is related to highlighting the X3F images for extraction which will be
explained below.
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Note: When you build and integrate a custom sequence set, you are not deleting the X3Fs that you
have not included. Conceptually you are flagging the ones you want to be used in the processing.
The others are just ignored during the processing.
WARNING: If you build a custom sequence set and integrate it, and then decide to go back to default
(seven images), you must tick the ones you have un-ticked and re-integrate the seven. Closing and
reopening SPP without doing so does not reset the sequence set to default (7 images).
Processing the integrated X3I file in the REVIEW WINDOW
Click the FILE and then select Review Images. You will get a warning message if you have not
integrated at least three (3) images. If you have not integrated your choices, the message, “Integrate
X3F files?” will be displayed. Make sure your ticks are correct and then click Yes, even if you have
done this already. The X3I EDIT WINDOW is then closed and the REVIEW WINDOW is opened with
your X3I file. Editing options are the same as with an X3F file.
Processing the integrated X3I file in the Alternate REVIEW WINDOW
Click the JPEG TIFF button at the top left or click the File tab and then select Save Images As. You will
get a warning message if you have not integrated at least three (3) images and you may get the
"Integrate X3F files?" message. Make sure your ticks are correct and then click Yes even if you have
done this already. A window will be displayed above the thumbs with three options. You cannot do
any type of editing yourself. Just sit back and wait and enjoy a cup of Java.
• X3I/X3F - The associated (saved or default) X3I settings are used. You have a choice of G1,
G2, or G3 for color. Default settings are listed in the Getting Started section above.
• Auto - The settings are computed automatically and applied to the image.
• Custom - If you have a custom setting, a drop-down allows you to select it from your list. For
information on creating a custom setting refer to the SPP Help Manual.
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Alternate Review Window
Extracting individual RAW files for processing by SPP or for use with external editor/browser
1. Open the X3I file in the X3I Edit Window. Highlight the one(s) you want to extract.
Note: The tick marks are for selecting which X3Fs are used only to build the sequence set.
2. Click the Edit tab and choose Copy the X3F of Selected Frames. Paste them CTRL+V/CMD+V)
(Windows/Mac) into the window Finder/Explorer window of your choice. You can paste
right into the open MAIN WINDOW. You will not see the X3F files unless you have your View
options set appropriately. You can also highlight, CTL+C/CMD+C and paste CTL/CMD+V or
highlight and click the X3F button (right-most button of top group) and then and then paste
CTL/CMD-V. The folder you paste into must be open and not just highlighted or back-lit.
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For A Better SFD Shot
Equipment and Set-up
SFD at this stage does not handle movement well. It takes the camera about 7 to 8 seconds to take
all 7 shots. Part of this time is the lag between the 6th and 7th shot which occurs with the sd
Quattro, and sd Quattro H but not with the dp Quattro series. If you have unexpected motion
artifacts, you may want to try excluding the last shot when you process the X3I file.
Do not try shooting without some kind of solid support. As good as you may be at hand-holding, you
cannot provide a solid support. Turn off OS as it will not help you. A solid tripod with a strong head
is extremely important. The base support for your tripod is equally important. The firmer and more
rigid the ground the better off you will be. Hills are inherently less stable than level ground.
Balancing your system fore and aft is another action that can help reduce shake/vibration. Heavy
lenses should have a collar which can be used for balancing and for rotation when shooting vertical
or off-axis shots. Since some very heavy lenses do not have collars, an Arca-Swiss type mount with
an extra long collar can help with balancing.
Reduce the chance of vibration or shake due to the pressure on the shutter button. Use a 10-second
delay and back away from the camera until you are absolutely certain that all shots have been taken.
Subject Selection
•

Subjects with high dynamic range — deep shadows and bright/strong highlights will get the
greatest benefit from SFD. Its 7 bracketed shots enable it to pull detail out of deep shadow
and reduce and recover detail from blown highlights.

•

Flat light can also benefit as SFD integrates the best detail from each exposure. The same
applies to high-overcast images.

•

Avoid any shots with motion. Naturally this includes any types of action/sports shots.

•

Clouds can be an issue also as although they may not appear to be moving, very few clouds
stay still for very long. This is also true of leaves, branches and people.
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